Problem : "Co-sell error stating CRM Sync Failed"
Issue:
["source=SalesForce, message=CRM sync failed, CoSell request to CRM failed, status : Forbidden, response : [{\"message\":\"This session could not be mutually authenticated for use with the REST API\",\"errorCode\":\"MUTUAL_AUTHENTICATION_FAILED\"}]"]
Root Cause:
If you encounter the above Co-sell sync error, it may be due to the password issue of the connected Salesforce user. Please refer to the two solutions below to resolve the issue.
Resolution 1: Update Password Policy
Follow the steps below to set the password policy for the connected user to Never Expire:
Click on the Gear icon and select Setup.
Search for Password Policies in the Quick Find box.
Set User passwords expire in to Never Expires.
Save the changes.
Resolution 2: Reset Password
Reset the password for the connected Salesforce user, and then revalidate the SaaSify ↔ Salesforce connection.